510? History Anyone
+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: 510? History Anyone

  1. #1
    Join Date
    Dec 2001
    Location
    Prescott, AZ, USA.
    Posts
    426

    Default 510? History Anyone



    POR 1974

    Roger

  2. Remove Advertisements
    SpecialStage.com
    Advertisements
     

  3. #2
    Join Date
    Dec 2001
    Location
    Grosse Pointe Park, MI, USA.
    Posts
    1,443

    Default

    I'm pretty sure it's not 1974 POR. Car in background has SCCA PRO Rally door backer & POR was WRC that year. Also, I don't remember that car from that rally. Brian McMahon took the pic. He lurks around the forums, so maybe he can clarify.

  4. #3
    Join Date
    Dec 2001
    Location
    San Diego, CA USA.
    Posts
    1,368

    Default

    I remember seeing that car at POR in 1980 or 81.

  5. #4
    Join Date
    Dec 2003
    Location
    SE Michigan.
    Posts
    147

    Default

    Would you believe a welder from Calgary! I had his card until a few years ago.
    The owner-driver standing at the rear of the car. It was chopped due to a wreck I believe he said. He claimed the cornering was something else.

    I was at the right spot when the sleet hit later on.






    And that was the last time I saw him.
    “It might be easier to buy a ballpean hammer and hit themselves in the face for three days. That way they would get the same kind of pain and it would cost them a lot less money.”

  6. #5
    Join Date
    Dec 2001
    Location
    Prescott, AZ, USA.
    Posts
    426

    Default

    Brian McMahon right? You have some really great old rally pictures on your site, do you want it public? It is a really interesting look back into what people brought to the table, weird and wonderful cars and trucks way back when, what year do you think that was and where? Wheelbase on the think must have been about 80+ or - inches as opposed to the normal 510 at 95.3 ", no wonder it spun like a top on the slick.

    Roger

  7. #6
    Join Date
    Dec 2001
    Location
    Wisconsin (was-Michigan)
    Posts
    3,898

    Default 1980 POR

    I'm guessing these guys (since the number matches):

    Ronald Schryer / Alan Baxter from Winnipeg Manitoba.

    http://www.rallyracingnews.com/scca/rally/por80.html

    No, I don't remember them.

    Winker? you were there in a 510.

    Cousin Brucie? you were there in an X1/9.

    Nowicki? in a 510.

    Uncle Joe? in a Colt.

    Kowalski? in a Hornet.

    press on,
    just a poor, dumb, Michigan(now Wisconsin) navie
    KC8YHT
    jimmy

  8. #7
    Join Date
    Dec 2001
    Location
    Greenville, Michigan, US.
    Posts
    816

    Default

    I have photos of the car . I remembered POR but not the year. I also remembered a Canadian plate but not the province.

    Reply hazy- try again.
    Bruce Beauvais
    de N8WLF

  9. #8
    Join Date
    Dec 2003
    Location
    SE Michigan.
    Posts
    147

    Default

    Roger, It is 'Mad Mikes' site He up-loaded my files. I put all that stuff out there so folks like you could look and see what the beginnings of the sport when stage rally took off. Enjoy!



    Did you listen to the Hairy Canary hit the tree? It's in the sound section.
    “It might be easier to buy a ballpean hammer and hit themselves in the face for three days. That way they would get the same kind of pain and it would cost them a lot less money.”

  10. #9
    Join Date
    Dec 2001
    Location
    Prescott, AZ, USA.
    Posts
    426

    Default

    Do you think he's going to need more tools than he brought?

    [/IMG]

    Roger
    Last edited by Roger Hull; 05-24-2010 at 09:48 PM.

  11. #10
    Join Date
    Sep 2009
    Location
    South Bend, Indiana
    Posts
    26

    Default

    Quote Originally Posted by jimmy View Post
    I'm guessing these guys (since the number matches):

    Ronald Schryer / Alan Baxter from Winnipeg Manitoba.

    ...

    No, I don't remember them.

    Kowalski? in a Hornet.
    Hi, Jimmy, I'd have to say that I don't really remember them either. The more I look at the picture, though, it seems like I may be creating a false memory since it does look slightly familiar (like I may have seen it when I was wandering around before the start).

    Now if they could've stuck a Dino engine mid-ship for traction...

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts